Sometimes I will feel a little bit of sorrow, that I do not know where to forward.
Many people call it at sea.

Yesterday night I feel little bit of at sea, thus I downloaded ADT for my linux.
and I encountered some problems about the shared library for C++, now I’d like to share the solution to you all:

Even though I already installed zlib-dev and libstdc++-4.8-dev, eclipse keep tells me my linux can not find libz and libstdc++.
What a stupid!.

the ldd tells me it want to use the lib from below path:

[rugal@rugal-TM8473 platform-tools]> ldd /opt/adt-bundle-linux/sdk/platform-tools/adb =>  (0xf7767000) => /lib/i386-linux-gnu/ (0xf7740000) => /lib/i386-linux-gnu/ (0xf773b000) => /lib/i386-linux-gnu/ (0xf771f000) => /usr/lib/i386-linux-gnu/ (0xf7636000) => /lib/i386-linux-gnu/ (0xf75f3000) => /lib/i386-linux-gnu/ (0xf75d6000) => /lib/i386-linux-gnu/ (0xf7422000)

But my lib was in:

[rugal@rugal-TM8473 platform-tools]> dpkg -S
libstdc++6:amd64: /usr/lib/x86_64-linux-gnu/
libstdc++6:amd64: /usr/lib/x86_64-linux-gnu/

Here I got an idea that, seems ADT can only make use of 32-bit of lib…
what a stupid…

Hence I installed 32-bit library for libstdc++ and libz

sudo apt-get install lib32z1-dev
sudo apt-get install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386

in some release, you need to use

sudo apt-get install ia32-libs

All things are done! But today, I get back of myself, I still want to deepen my future into database.
So I deleted the ADT…that is all I have done yesterday.


10 January 2014